Skip to content

It runs!!!

February 29, 2012

I had my cousin and Alan over tonite to help out with the spec car, but my main objective was to start the car up for the first time. Since we dont have the fitting for the return fuel line yet, i decided to drop the return into a gas can and try starting the car as is. We called Sam on speaker phone, cranked the car a couple times and it fired right up. Only issue was one fouled plug and after cleaning it up the car ran perfect for a few minutes with awesome oil pressure. Even checked the tach signal on the Tracmate and it works!  So now we know that the car will run, time to start putting things back together. Alan and Jim helped put the hatch and the hood back on, Jim put the hood latch back together and installed the tow straps through the bumpers. Doesn’t sound like much but the car is way closer now to being finished. This week the brake lines, fuel lines and a couple small other parts are coming and we should have brakes, clutch and a running car that can be driven up the street! Even getting the windshield in friday, so we are in the home stretch.

 

Advertisements

From → Uncategorized

Leave a Comment

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: